Known errors, warnings, workarounds and fixes for Microsoft Exchange backups with M365 backup powered by Veeam


TABLE OF CONTENTS

Description

Here is a list of known workarounds and fixes for warnings and errors you may get in your backup reports for Microsoft Exchange.


 

Warning: Processing mailbox xxxxxxx@xxxxxxx.OnMicrosoft.com completed with warning: Mailbox does not have a valid Microsoft 365 license
 

Cause :

It is a requirement to have a valid M365 license for each user included in backup jobs.


Solution :

Please make sure to assign an active M365 license on the user. Please follow this Microsoft article for more information on assigning M365 licenses to users.

If backup is not desired for this user, you can add the user to the security group named ExcludedUsersForM365BackupPoweredByVeeam in Azure Active Directory.



Warning: Processing mailbox xxxxxxxxx completed with warning: Failed to find group owner account


Cause :

Impersonation is not possible if Office 365 groups (mail-enabled and security groups) do not have an owner.


Solution :

Please make sure to assign an owner to each of the Office 365 groups (mail-enabled and security groups). Please follow this Microsoft article for more information on assigning an owner on ophaned groups.



Error: The identity of the calling application could not be established.


Cause :

The enterprise application named "M365 backup powered by Veeam" was deleted in Azure AD. Backup jobs cannot run without this application.


Solution :

Please contact our support team. We will have to proceed with the Microsoft tenant setup again in the backend using a user with the Global Administrator role.